Author Topic: UJK drill guide and centrotec, big disappointment (don’t buy)  (Read 1719 times)

0 Members and 1 Guest are viewing this topic.

Offline threesixright

  • Posts: 655
Hi All,

Finally got time (and a project) to drill a bunch of holes with the UJK drill guide.

Unfortunately a big disappointment when used together with FT centrotec  [mad].

Problem is the guide basically slips of. I was coming down my ladder, holding the Drill (attached the guide), the guide fell basically off [blink]. Damaging the drill bit.

At first I thought it was my own fault, but after some testing it seems you can just pull the drill of the guide without holding the centrotec release sleeve.

Currently, I see that axminstertools doesn’t mention Festool or centrotec anymore. But I’m 100% sure when I bought it (thats some time ago) it was mentioned at the time (maybe even in the video).

All in all, don’t buy if you intent to use it with Festool. You need to hold both (drill and guide) when moving it around wich is very uncomfortable. Simply not worth the premium price, I would call it junk.

UJK sorry for the bad review, but this IMHO a big design flaw.


Rog.

Festool USA does not pre-approve the contents of this website nor endorse the application or use of any Festool product in any way other than in the manner described in the Festool Instruction Manual. To reduce the risk of serious injury and/or damage to your Festool product, always read, understand and follow all warnings and instructions in your Festool product's Instruction Manual. Although Festool strives for accuracy in the website material, the website may contain inaccuracies. Festool makes no representations about the accuracy, reliability, completeness or timeliness of the material on this website or about the results to be obtained from using the website. Festool and its affiliates cannot be responsible for improper postings or your reliance on the website's material. Your use of any material contained on this website is entirely at your own risk. The content contained on this site is provided for informational purposes only and does not constitute professional advice.


Offline Euclid

  • Posts: 273
I've not encountered that problem with mine.

I couldn't recall to what extent I'd moved the thing around just holding onto the drill (thus far, I've used it exclusively with Centrotec drills)... so I've just tried it out and I cannot pull the drill from the drive shank without releasing the chuck sleeve, however hard I pull or jerk it, even holding the guide down with the other hand.

Has, perhaps, your Centrotec chuck become a little worn and  looser? They work on, essentially, the the same principle that's used on racing car steering wheels and I've had one of those become sloppy over time (but replaced before it became a danger!).

What could well be a problem (when, for example. climbing down a ladder and just holding the drill) is that the carriage might slide up and knock the protecting caps off of the rods and let the rest of the guide drop. I've not yet used it in a situation where that would be a risk, but I do have a couple of extra collar-stops to fix above the carriage to stop that.

(In the interests of balance, I've been very pleased with mine!)
:-)

Offline scholar

  • Posts: 149
That sounds annoying.

I am interested as I have had my eyes on one of these (but it was out of stock for a long time).

The details do state it is Centrotec compatible and the pictures show the hex spigot having the double detent to fit both standard and Centrotec hex connectors.



Sounds like the machining may be slightly out on your spigot - have you tried it with different Centrotec chucks?

[I hope I would have checked the functioning before dangling the unit off a ladder, though]

Cheers

Offline threesixright

  • Posts: 655
Hi,

Thanks for the feedback.

I used a brand new TDC 18/4 with it. So I would rule out wear on of the centrotec.

When I connect the drill I hear the positive click (it sounds like its locked), then pulling ion the dril with a bit of force (and I am by no means Hercules) I pull the drill of.

When i came down the lader, I just had the drill in my hand and moving my arm forward, the guide basically flew off (on the ground).

I can try it with CXS to see if thats any better. Will make some pics tomorrow, maybe can shoot a video.

Extremely frustrating.

Drilling itself is good, was happy with it (working on the roof need to drill some straight holes, so that maybe not the normal use-case).
« Last Edit: May 21, 2022, 08:42 AM by threesixright »

Offline Euclid

  • Posts: 273
I've just noticed that one of my Centrotec chucks takes an extra little push to fully engage - a second 'click' as it were - on the UJK guide. (Rather like the two-stage positioning with the aforementioned race car wheels - 1, engagement, then 2, locked - but much less pronounced.)
Thinking about it, I've noticed the same thing with one or two other third-party 'Centrotec-compatible' items.

Offline Euclid

  • Posts: 273
<< Extremely frustrating.>>

Indeed, I can imagine... did the drill guide stand itself survive the fall?

Offline threesixright

  • Posts: 655
<< Extremely frustrating.>>

Indeed, I can imagine... did the drill guide stand itself survive the fall?

Yeah it looks good, dropped max 1 meter. Just the drill bit slightly damaged.

Offline Bob D.

  • Retailer
  • *
  • Posts: 3038
    • My Cordless Workshop
I last used mine for some angled drilling over a year ago. I just checked and do not have this problem with my T15 and Centrotec chuck. I had never used the T15 with the UJK guide, I always used my Milwaukee with the 1/4" hex drive for quick connect/disconnect.

Since I have not used it in over a year I will am considering selling it. It's just collecting dust. For what I do one of my DPs does the job and if not I can use other drill guides I already have.
-----
It's a table saw, do you know where your fingers are?

Offline threesixright

  • Posts: 655
Re: UJK drill guide and centrotec, big disappointment
« Reply #8 on: May 23, 2022, 11:09 AM »
Hi All,

Thank you all for the feedback. I also tested it with my CXS, same issue. Good to hear I am the only one.

I talked to axminister today, sent them a video. I guess this is unfortunately an issue with my version.

Their tech. team will contact me. I will report back what happens.

Here is a link to the video:

https://e1.pcloud.link/publink/show?code=XZDiFRZKrQrfMpJMPSIgH0JbhfJtYeUU1r7
« Last Edit: May 23, 2022, 11:14 AM by threesixright »