Author Topic: CT MIDI I connecting to a Domino 500  (Read 606 times)

0 Members and 1 Guest are viewing this topic.

Offline houstonotsuoh

  • Posts: 2
CT MIDI I connecting to a Domino 500
« on: September 01, 2021, 07:13 PM »
I have the MIDI dust ex. and just got the Domino 500 but the dust hose will not connect and not founding an adapter that makes sense.
Any advise, thanks.

Festool USA does not pre-approve the contents of this website nor endorse the application or use of any Festool product in any way other than in the manner described in the Festool Instruction Manual. To reduce the risk of serious injury and/or damage to your Festool product, always read, understand and follow all warnings and instructions in your Festool product's Instruction Manual. Although Festool strives for accuracy in the website material, the website may contain inaccuracies. Festool makes no representations about the accuracy, reliability, completeness or timeliness of the material on this website or about the results to be obtained from using the website. Festool and its affiliates cannot be responsible for improper postings or your reliance on the website's material. Your use of any material contained on this website is entirely at your own risk. The content contained on this site is provided for informational purposes only and does not constitute professional advice.


Offline Chainring

  • Posts: 103
Re: CT MIDI I connecting to a Domino 500
« Reply #1 on: September 01, 2021, 08:01 PM »
The hose that comes with the Midi I should have the 27mm tool end on there and that slips right onto the DF 500 dust port. If that's not working for you, something ain't quite right. Post a picture of your hose and collection point on the 500.

Offline ChuckS

  • Posts: 2885
Re: CT MIDI I connecting to a Domino 500
« Reply #2 on: September 01, 2021, 08:08 PM »
Unless it's a defect, the CT mini or midi hose fits into the DF dust port. Does need a bit of force and try angling the hose slightly as you push it.

« Last Edit: September 01, 2021, 08:10 PM by ChuckS »

Offline squall_line

  • Posts: 775
Re: CT MIDI I connecting to a Domino 500
« Reply #3 on: September 01, 2021, 11:18 PM »
Literally the first time I used my Domino 500 was with a MIDI I with the stock hose, so I'm 99% certain they're compatible.  As others have said, the collection can be a pain to put on.  Page 12 of the manual that's in my Systainer has tips on how to attach the hose, but they show the old style of collection port, not the new twist-lock.

For the twist-lock, line the arrow on the hose nozzle up with the line on the collector port of the Domino.  Force it on to the port, then twist clockwise to line the arrow of the nozzle up with the arrow on the port.  To remove, reverse the steps.

Pictures below.  Hope this helps!

335107-0
335109-1

Offline houstonotsuoh

  • Posts: 2
Re: CT MIDI I connecting to a Domino 500
« Reply #4 on: September 02, 2021, 08:15 AM »
the midi plugs and locks into place real nicely with the track saw 75 and just dont understand why this does not happen with the domino.

Online benz240

  • Posts: 18
Re: CT MIDI I connecting to a Domino 500
« Reply #5 on: September 03, 2021, 08:43 AM »
the midi plugs and locks into place real nicely with the track saw 75 and just dont understand why this does not happen with the domino.

Did you line up the arrows?