Having trouble with your Festool power tool? Well, we're here to help you. Before posting to the forum, give us a chance to diagnose and resolve your issue. In the U.S. and Canada, call us toll-free at 888-337-8600 on Monday-Friday between 8a-5p EST or contact us via email at service@festoolusa.com. For other countries, please visit http://www.festool.com for contact information for your local Festool service department.

Author Topic: Did I destroy my CT36? Water ingress at turbine possible.  (Read 524 times)

0 Members and 1 Guest are viewing this topic.

Offline ChristopherT

  • Posts: 2
Did I destroy my CT36? Water ingress at turbine possible.
« on: January 04, 2021, 01:41 PM »
I cleaned the top of unit (on the inside) with a spray of water where the cover to the turbine is. I figured this was safe because it well sealed and, well, it's indestructible. Now when I turn the switch to MAN it starts for a half second then shuts off. The AUTO outlet works, but does not trigger the suction motor. I took off the turbine cover, and removed all the sound dampening foams, but no go!

Festool USA does not pre-approve the contents of this website nor endorse the application or use of any Festool product in any way other than in the manner described in the Festool Instruction Manual. To reduce the risk of serious injury and/or damage to your Festool product, always read, understand and follow all warnings and instructions in your Festool product's Instruction Manual. Although Festool strives for accuracy in the website material, the website may contain inaccuracies. Festool makes no representations about the accuracy, reliability, completeness or timeliness of the material on this website or about the results to be obtained from using the website. Festool and its affiliates cannot be responsible for improper postings or your reliance on the website's material. Your use of any material contained on this website is entirely at your own risk. The content contained on this site is provided for informational purposes only and does not constitute professional advice.


Offline ChristopherT

  • Posts: 2
Re: Did I destroy my CT36? Water ingress at turbine possible.
« Reply #1 on: January 04, 2021, 03:27 PM »
Solution: Took everything apart, sprayed WD-40 on the board followed by gentle compressed air. I assume the board was wet and the "max fill" switch was closing.

Offline Alex

  • Posts: 7249
Re: Did I destroy my CT36? Water ingress at turbine possible.
« Reply #2 on: January 04, 2021, 03:47 PM »
Please, do not ever do all these things which I read in your two posts above again to your dear CT36.

Clean it? Just a damp cloth with soap or ammonia, nothing more.